PDA

View Full Version : Help!!!!



nogoodreezen
05-04-2011, 05:40 PM
OK here is the story. I traded for a 2009 Z28 last week and I love it. I was getting a little fletching contact with my qad so I went back to the shop to work on it. We were trying to paper tune it to get some idea of what was going on. It turns out the rest was hitting the shelf because the mounting holes are so low. Nothing we could really do....Tried the new TR Revolution, and several other rests and none would tune out far enough to the left. I finally just stuck a WB on it because it was the only rest that would tune out far enough to the left. ***? Am I the only person who has ever had this problem and if not what can I do. The WB is shooting bullet holes and I'll probably just stick with it for now. I really liked the Revolution though.

Cajun Blake
05-04-2011, 06:06 PM
welcome to the fam

wish I could be of more help , but all I've ever shot was LimbDrivers and never had a problem

someone will chime in soon with a fix

nogoodreezen
05-04-2011, 06:23 PM
Thanks. Glad to be a member of the family. I was contacted by a guy earlier who said he had the EXACT same problem. He warned me it would sound strange before he told his story. Long and short of it he said he was told by Elite to swap the top and bottom limbs. Guy swears this instantly fixed everything and his bow tuned perfectly. Something about the deflection being different and some 2009's were shipped with the limbs wrong. Any thoughts? I don't know what to think about it.

DustyRx
05-04-2011, 06:34 PM
As long as your arrows are the correct spine then yes swap the limbs around and try that. I had to do that to my '09 Z.