Results 1 to 7 of 7

Thread: Limbdriver Pro-V on GT 500 problems... please help

  1. #1
    Junior Member Fawn
    Join Date
    Mar 2011
    Location
    Great White North
    Posts
    5

    Default Limbdriver Pro-V on GT 500 problems... please help

    I have a 2010 gt500 shoots like a dream but i cant get the center shot properly set on my bow. just bought a new limbdriver because i thought i was getting contact on my old rest but it comes out odd regardless... thinking cam lean ... any thoughts??

  2. #2
    Respected Member Ten Point bfoot's Avatar
    Join Date
    Apr 2010
    Location
    St. Louis, MO
    Posts
    1,232

    Default

    I would check the shims and make sure they have not been reversed. Have the cams been off recently? Sometimes the thick shims are put on the wrong side and the centershot is off.
    15 Elites - 1 GTO, 3 E-500s, 1 Synergy, 2 SynXTs, 4 Envys, a 2008.5 Z28, 2 2008.5 GT500, a Aigil, Impulse
    2 K&K Vengeance , 2011 PSE Axe 6, 2011 Hoyt Carbon Element, Four Tributes and one Allegiance

    Frankenbow Freak

  3. #3
    Junior Member Fawn
    Join Date
    Mar 2011
    Location
    Great White North
    Posts
    5

    Default

    Cams have never been off but the centershot seems to be quite far away from the riser. like unusually away from the riser.

  4. #4
    Junior Member Fawn
    Join Date
    Mar 2012
    Posts
    3

    Default

    Yep, I feel your pain. Im about to quit messing with mine and sell it. Customer service has been awesome but I'd rather be shooting than dealing with the issues. I'm gonna call Dick at Elite next Friday (day off) and see if he can help point me in the right direction. If that doesn't work .............




    Sent from my DROID BIONIC using Tapatalk

  5. #5
    Senior Member Four Point bow_dude's Avatar
    Join Date
    Mar 2009
    Location
    Salt Lake City, Utah
    Posts
    212

    Default

    Is the rest timed properly? Could be getting bounce up if too strong and not enough clearance if too weak. I have 2 GT500's with limb drivers on both. My shooting consistency is the best it has ever been. Been using the rest for a couple of years.

  6. #6
    Member Spike
    Join Date
    Feb 2012
    Location
    Platte City, MO
    Posts
    55

    Default

    I think my answer may have reversed shims from the original speed mod install. What side do the different shims go on? My centershot is way out at 1.25".

  7. #7
    Respected Member Ten Point bfoot's Avatar
    Join Date
    Apr 2010
    Location
    St. Louis, MO
    Posts
    1,232

    Default

    Here is some information on spacers on the GT50 from an old post:

    I purchased a "problem" GT 500 off of a friend a few days ago and followed marzomi's advice: I contacted Elite and requested the shim kit and inserted 2 .045 shims on the left side and 1 .035 shim on the right side. The bow is now shooting as good as my Fury X tuned GT 500 (just not as fast); my buddy wants to buy it back now. The CS is 7/8" and BH and Field points are grouping together at 50yds and it shoots bullet holes thru paper with Maxima 350's and Victory V Force HV1 .300's. This was the solution for this "problem" GT 500. Thanks for sharing.




    Here is the original post: http://www.elitearchery.com/forums/s...ht=GTO+spacers

    There are six pages of information about getting the center shot correct on the GT500 and Kevin Strother himself makes several comments on spacer size and other pertinent information.

    This is a problem many GT500s had and this will fix it.
    15 Elites - 1 GTO, 3 E-500s, 1 Synergy, 2 SynXTs, 4 Envys, a 2008.5 Z28, 2 2008.5 GT500, a Aigil, Impulse
    2 K&K Vengeance , 2011 PSE Axe 6, 2011 Hoyt Carbon Element, Four Tributes and one Allegiance

    Frankenbow Freak

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •